Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 11, 2025 - 13:53 UTC
Scheduled
Maintenance Window: UTC - From 12:30p to 15:30 Tuesday, November 11, 2025 EST - From 08:30a to 11:30a Tuesday, November 11, 2025 IST - From 15:30 to 18:30 Tuesday, November 11, 2025
Activity: SafeBreach will perform scheduled maintenance to the platform's UI on Tuesday, November 11, 2025. Customers will not experience any service disruptions during this scheduled maintenance window. There's some possibility that some customers may need to login to the the console again. For up-to-date information on SafeBreach release details, please see: https://docs.safebreach.com/docs/safebreach-release-notes
FOR MORE INFORMATION Please visit SafeBreach Status for the latest status updates. If you have questions, please open a ticket via our portal at https://support.safebreach.com or by email at support@safebreach.com.
Posted Nov 11, 2025 - 13:32 UTC
This scheduled maintenance affected: SafeBreach Cloud Management Consoles.