Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 18, 2025 - 12:30 UTC
Scheduled
Maintenance Window: UTC - From 10.30am to 12.30 Tuesday, March 18th, 2025 EST - From 6.30am to 8.30am Tuesday, March 18th, 2025 IST - From 12.30 to 2.30 pm Tuesday, March 18th, 2025
Activity: SafeBreach will perform scheduled maintenance to backend data stores on Tuesday, March 18th, 2025. Customers will not experience any service disruptions during this scheduled maintenance window. For up-to-date information on SafeBreach release details, please see: https://docs.safebreach.com/docs/safebreach-release-notes
FOR MORE INFORMATION Please visit SafeBreach Status for the latest status updates. If you have questions, please open a ticket via our portal at https://support.safebreach.com or by email at support@safebreach.com.
Posted Mar 18, 2025 - 10:13 UTC
This scheduled maintenance affected: SafeBreach Cloud Management Consoles.